Forum Coders' city Strona Główna Coders' city
Nasza pasja to programowanie!
 

 PomocPomoc   SzukajSzukaj   UżytkownicyUżytkownicy   GrupyGrupy  RejestracjaRejestracja 
Archiwum starego forum + teoria    RSS & Panel/SideBar
 ProfilProfil   Zaloguj się, by sprawdzić wiadomościZaloguj się, by sprawdzić wiadomości   ZalogujZaloguj 

Potrzebuję szybkiej odpowiedzi na moje pytanie... Zasady

[FASM] Nieprawidłowe działanie kodu



 
Odpowiedz do tematu    Forum Coders' city Strona Główna -> Elektronika, programowanie niskopoziomowe
Zobacz poprzedni temat :: Zobacz następny temat  
Autor Wiadomość
qqqq
Gość





PostWysłany: Nie Paź 28, 2012 11:47 am  OP    Temat postu: [FASM] Nieprawidłowe działanie kodu Odpowiedz z cytatem Pisownia

Witam forumowiczów. Mam taki problem - w kompilatorze FASM kompiluję poniższy kod:
Kod:

;ustawianie trybu graficznego
mov ah,00h
mov al,12h   ;13 mniejszy   ;12 większy
;int 10h
int 10h
; rep stosw          ;czyszczenie ze śmieci

;rysowanie

mov ah, 0ch
mov es, ax
mov di, 640*20+20   ;320*dx+ cx
mov al, 10
mov [es:di],al


int 10h

Lecz działa on nieprawidłowo. Po pierwsze wyświetla piksel o innym kolorze. po drugie, pojawia się jakiś śmieć na ekranie i zmienia on kolor. Czy ktoś wie jak to można zmienić? Mam też drugie pytanie - czy ktoś wie jak można włączyć tryb graficzny VESA i jak z niego korzystać? pozdrawiam.
Powrót do góry
Wyświetl posty z ostatnich:   
Odpowiedz do tematu    Forum Coders' city Strona Główna -> Elektronika, programowanie niskopoziomowe Wszystkie czasy w strefie CET (Europa)

Strona 1 z 1

 
Skocz do:  
Możesz pisać nowe tematy
Możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Możesz dodawać załączniki na tym forum
Możesz pobierać pliki z tego forum




Debug: strone wygenerowano w 0.10698 sekund, zapytan = 11
contact

| Darmowe programy i porady Jelcyna | Tansze zakupy w Helionie | MS Office Blog |