Strona: [  << <   1   > >>  ]  z  1     
Autor Temat: Problem z Tabstrip
DJK



Typ: neutral
Postów: 871
Zarejestrowany: Feb 2004
Problem z Tabstrip

Witam

Mam funkcję

Public Sub SetTabHeaderIcon(ByVal iTab As Integer)
Dim tabHdr As TCITEMHEADER

With tabHdr
    .mask = 1
    .pszText = "aaa"
    .cchTextMax = 3
End With

Call SendMessage(TabStrip1.hwnd, TCM_SETITEM, ByVal iTab-1, tabHdr)

End Sub


która w zakładce o numerze iTab zmienia Teskt na "aaa".

Pytanie: czemu to nie działa gdy wywołuję funkcję w Form_Load albo Form_Activate (tutaj działa dopiero gdy przed wywołaniem funkcji dam DoEvents) ??

Pytanie - czy Form_Activate wywoływane jest tylko raz po wczytaniu programu ??

[Post edytowany dnia 13-02-2005 16:29 przez DJK]


_____________________________________________
Jeśli można coś zrobić w sposób optymalny to czemu nie

13-02-2005 16:26
Pokaż profil DJK  Wyślij email do DJK   Odwiedź stronę DJK  
losmac
"profesorek"




Typ: neutral
Postów: 758
Zarejestrowany: May 2003


Pytanie - czy Form_Activate wywoływane jest tylko raz po wczytaniu programu ??


Nie raz, a za każdym razem, gdy form staje się aktywny.
Load występuje tylko raz!


_____________________________________________
POSTULATY STARUSZKA:
1) Ludzie, dbajcie o polszczyznę!!!
2) Ludzie, zadawajcie kompletne pytania, a nie rzucacie ochłapy i trzeba się domyślać o co chodzi!!!

Powodzenia
Maciej Łoś

13-02-2005 21:15
Pokaż profil losmac  Wyślij email do losmac   Odwiedź stronę losmac  
Wszystkich odpowiedzi: 1 :: Maxymalnie na stronę: 20
Strona: [  << <   1   > >>  ]  z  1