Strona: [  << <   1   > >>  ]  z  1     
Autor Temat: WinSocket - Adress in Use
Staszek




Typ: neutral
Postów: 46
Zarejestrowany: Dec 2003
WinSocket - Adress in Use

Witam,
mam problem i nie umiem go rozwiazac.. czy ktos wiec czemu co jakis czas winsocket przy probie polaczenia mowi "adress in use" (restart programu nie pomaga),a po zmianie juz dziala ?
z niecierpliwoscia czekam na odpowiedzi
Staszek

[Post edytowany dnia 11-12-2004 09:43 przez Staszek]


_____________________________________________
PZdr. St ()

"Nie mysl jak napisac ! Mysl co napisac !" Swiete slowa .. Of corz moje =p

11-12-2004 09:42
Pokaż profil Staszek  Wyślij email do Staszek        2620939
marcin_an
Forumowicz




Typ: neutral
Postów: 1265
Zarejestrowany: Mar 2004

Winsock (ogólnie, nie kontrolka) po rozłączeniu przez 2 minuty (a tak naprawdę nawet 4) oczekuje na danym porcie na dalsze pakiety. Dopiero po tym czasie można ponownie użyć tego portu. Ponieważ kontrolka Winsock nie pozwala na użycie opcji ponownego użycia tego portu (tj. w momenice, gdy jest już używany przez inną aplikację) - nie da się tego niestety ominąć.
Są dwa rozwiazania:
1) Poczekać 4 minuty
2) Uzyć po rozłaczeniu innego portu.


_____________________________________________
Jedzonko dla Google'a:
Forum na temat Visual Basic, C, C++, Pascal, Programowanie, API, PHP, VBA, VB.NET, QBasic, VBScript, Komputery
Moja strona o wszystkim

11-12-2004 10:09
Pokaż profil marcin_an  Wyślij email do marcin_an   Odwiedź stronę marcin_an  
Staszek




Typ: neutral
Postów: 46
Zarejestrowany: Dec 2003

Dzieki za odpowiedz


_____________________________________________
PZdr. St ()

"Nie mysl jak napisac ! Mysl co napisac !" Swiete slowa .. Of corz moje =p

11-12-2004 12:12
Pokaż profil Staszek  Wyślij email do Staszek        2620939
Wszystkich odpowiedzi: 2 :: Maxymalnie na stronę: 20
Strona: [  << <   1   > >>  ]  z  1