Strona: [  << <   1   > >>  ]  z  1     
Autor Temat: Znikająca ramka
mikmas
From Łódź Stadt




Typ: neutral
Postów: 772
Zarejestrowany: Apr 2003
Znikająca ramka

Mam se ramkę (frame). Nie wiem dlaczego nie mogę zrobić, żeby była widoczna! Ustawiłem właściwość Visible na True i w run mode ta wartość jest = false! W kodzie nawet wpisałem:

frame1.visible=true
if frame1.visible=false then msgbox "..."

No i niestety pojawia się komunikat! Czemu?


_____________________________________________
4C;65;70;69;65;6A;20;62;79;9C;20;73;69;EA;20;
62;61;72;64;7A;69;65;6A;20;73;6B;6F;6E;63;65;
6E;74;72;6F;77;61;B3;20;6E;61;20;6F;64;70;6F;
77;69;65;64;7A;69;2C;20;61;20;6E;69;65;20;6E;
61;20;72;6F;7A;73;7A;79;66;72;6F;77;79;77;61;
6E;69;75;20;3A;50

05-11-2004 14:19
Pokaż profil mikmas  Wyślij email do mikmas   Odwiedź stronę mikmas       3632553
DJK



Typ: neutral
Postów: 871
Zarejestrowany: Feb 2004

No możesz więcej szczegółow ??

A ustawiłeś ZOrder bo może jakas inna kontrola ją przysłania??

Może podaj fragment kodu

Pozdrawiam

[Post edytowany dnia 05-11-2004 15:32 przez DJK]


_____________________________________________
Jeśli można coś zrobić w sposób optymalny to czemu nie

05-11-2004 15:31
Pokaż profil DJK  Wyślij email do DJK   Odwiedź stronę DJK  
bisiek




Typ: neutral
Postów: 487
Zarejestrowany: Jul 2003

No, raczej zorder nie ma znaczenia przy visible = false i jeżeli fragment kodu działa tak jak napisałeś to chyba jest wina vb, raz mi się zdarzyło że nie robił tego co trzeba bez żadnego powodu.


_____________________________________________
www.mob.abc.pl - moja strona o VB

05-11-2004 15:47
Pokaż profil bisiek  Wyślij email do bisiek   Odwiedź stronę bisiek       3380672
mikmas
From Łódź Stadt




Typ: neutral
Postów: 772
Zarejestrowany: Apr 2003

Czyli no nie ma żadnego sposobu na zrobienie, aby ramka się pojawiła?


_____________________________________________
4C;65;70;69;65;6A;20;62;79;9C;20;73;69;EA;20;
62;61;72;64;7A;69;65;6A;20;73;6B;6F;6E;63;65;
6E;74;72;6F;77;61;B3;20;6E;61;20;6F;64;70;6F;
77;69;65;64;7A;69;2C;20;61;20;6E;69;65;20;6E;
61;20;72;6F;7A;73;7A;79;66;72;6F;77;79;77;61;
6E;69;75;20;3A;50

05-11-2004 15:52
Pokaż profil mikmas  Wyślij email do mikmas   Odwiedź stronę mikmas       3632553
bisiek




Typ: neutral
Postów: 487
Zarejestrowany: Jul 2003

Jeżeli takie coś

frame1.visible=true
if frame1.visible=false then msgbox "..."

da ten msgbox, to raczej nie. Sprawdź jeszcze czy napewno nie ma tam jakiejś literówki.


_____________________________________________
www.mob.abc.pl - moja strona o VB

05-11-2004 16:05
Pokaż profil bisiek  Wyślij email do bisiek   Odwiedź stronę bisiek       3380672
Piotr T




Typ: neutral
Postów: 176
Zarejestrowany: May 2004


Mam se ramkę (frame). Nie wiem dlaczego nie mogę zrobić, żeby była widoczna! Ustawiłem właściwość Visible na True i w run mode ta wartość jest = false! W kodzie nawet wpisałem:

frame1.visible=true
if frame1.visible=false then msgbox "..."

No i niestety pojawia się komunikat! Czemu?


Wstaw DoEvents i sprawdź

frame1.visible=true
DoEvents
if frame1.visible=false then msgbox "..."


_____________________________________________
Visual Basic.NET - Mercedes dla programistów

05-11-2004 16:15
Pokaż profil Piotr T  Wyślij email do Piotr T   Odwiedź stronę Piotr T  
mikmas
From Łódź Stadt




Typ: neutral
Postów: 772
Zarejestrowany: Apr 2003

Dalej nic


_____________________________________________
4C;65;70;69;65;6A;20;62;79;9C;20;73;69;EA;20;
62;61;72;64;7A;69;65;6A;20;73;6B;6F;6E;63;65;
6E;74;72;6F;77;61;B3;20;6E;61;20;6F;64;70;6F;
77;69;65;64;7A;69;2C;20;61;20;6E;69;65;20;6E;
61;20;72;6F;7A;73;7A;79;66;72;6F;77;79;77;61;
6E;69;75;20;3A;50

05-11-2004 17:17
Pokaż profil mikmas  Wyślij email do mikmas   Odwiedź stronę mikmas       3632553
marcin_an
Forumowicz




Typ: neutral
Postów: 1265
Zarejestrowany: Mar 2004

Usuń tę ramkę, dodaj nową i zobacz, czy coś się zmieni...


_____________________________________________
Jedzonko dla Google'a:
Forum na temat Visual Basic, C, C++, Pascal, Programowanie, API, PHP, VBA, VB.NET, QBasic, VBScript, Komputery
Moja strona o wszystkim

05-11-2004 21:29
Pokaż profil marcin_an  Wyślij email do marcin_an   Odwiedź stronę marcin_an  
mikmas
From Łódź Stadt




Typ: neutral
Postów: 772
Zarejestrowany: Apr 2003

Dalej nic . Ba! Skopiowałem CAŁY modulik do notatnika i wpisałem mu tylko (z myślą, że coś w kodzie może pochrzaniłem):

frame2.visible=true

... I NIC! No już nie mam pomysłów...


_____________________________________________
4C;65;70;69;65;6A;20;62;79;9C;20;73;69;EA;20;
62;61;72;64;7A;69;65;6A;20;73;6B;6F;6E;63;65;
6E;74;72;6F;77;61;B3;20;6E;61;20;6F;64;70;6F;
77;69;65;64;7A;69;2C;20;61;20;6E;69;65;20;6E;
61;20;72;6F;7A;73;7A;79;66;72;6F;77;79;77;61;
6E;69;75;20;3A;50

05-11-2004 22:04
Pokaż profil mikmas  Wyślij email do mikmas   Odwiedź stronę mikmas       3632553
kicaj




Typ: neutral
Postów: 271
Zarejestrowany: Aug 2003

to moze przeslij komus kod np. mi to ten ktos sprawdzi to u siebie

05-11-2004 23:35
Pokaż profil kicaj  Wyślij email do kicaj        3914568
Chudy
[TLHW]Wiktor



Typ: moderator
Postów: 574
Zarejestrowany: Aug 2002

U mnie jest wporządku. Ramka się pojawia. Tylko w zdarzeniu Form_Load wszystkie ramki mają Visible False. Udostępnij pełny kod to może coś poradzimy.


_____________________________________________
Projekt "Thunder Cannons" nadchodzi...

07-11-2004 09:18
Pokaż profil Chudy  Wyślij email do Chudy   Odwiedź stronę Chudy       1220895
Wszystkich odpowiedzi: 10 :: Maxymalnie na stronę: 20
Strona: [  << <   1   > >>  ]  z  1